Debian DLA-1491-1 : tomcat8 security update

High Nessus Plugin ID 112230

Synopsis

The remote Debian host is missing a security update.

Description

Two security issues have been discovered in the Tomcat servlet and JSP engine.

CVE-2018-1336

An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service.

CVE-2018-8034

The host name verification when using TLS with the WebSocket client was missing. It is now enabled by default.

For Debian 8 'Jessie', these problems have been fixed in version 8.0.14-1+deb8u13.

We recommend that you upgrade your tomcat8 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/09/msg00001.html

https://packages.debian.org/source/jessie/tomcat8

Plugin Details

Severity: High

ID: 112230

File Name: debian_DLA-1491.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/04

Modified: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libservlet3.1-java, p-cpe:/a:debian:debian_linux:libservlet3.1-java-doc, p-cpe:/a:debian:debian_linux:libtomcat8-java, p-cpe:/a:debian:debian_linux:tomcat8, p-cpe:/a:debian:debian_linux:tomcat8-admin, p-cpe:/a:debian:debian_linux:tomcat8-common, p-cpe:/a:debian:debian_linux:tomcat8-docs, p-cpe:/a:debian:debian_linux:tomcat8-examples, p-cpe:/a:debian:debian_linux:tomcat8-user, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/09/02

Reference Information

CVE: CVE-2018-1336, CVE-2018-8034