Debian DLA-1489-1 : spice-gtk security update

High Nessus Plugin ID 112228

Synopsis

The remote Debian host is missing a security update.

Description

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

The issue has been fixed by upstream by bailing out with an error if the pointer to the start of some message data is strictly greater than the pointer to the end of the message data.

The above issue and fix have already been announced for the 'spice' Debian package (as DLA-1486-1 [1]). This announcement is about the 'spice-gtk' Debian package (which ships some copies of code from the 'spice' package, where the fix of this issue had to be applied).

[1] https://lists.debian.org/debian-lts-announce/2018/08/msg00037.html

For Debian 8 'Jessie', this problem has been fixed in version 0.25-1+deb8u1.

We recommend that you upgrade your spice-gtk packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00037.html

https://lists.debian.org/debian-lts-announce/2018/08/msg00038.html

https://packages.debian.org/source/jessie/spice-gtk

Plugin Details

Severity: High

ID: 112228

File Name: debian_DLA-1489.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/09/04

Modified: 2018/09/04

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gir1.2-spice-client-glib-2.0, p-cpe:/a:debian:debian_linux:gir1.2-spice-client-gtk-2.0, p-cpe:/a:debian:debian_linux:gir1.2-spice-client-gtk-3.0, p-cpe:/a:debian:debian_linux:libspice-client-glib-2.0-8, p-cpe:/a:debian:debian_linux:libspice-client-glib-2.0-dev, p-cpe:/a:debian:debian_linux:libspice-client-gtk-2.0-4, p-cpe:/a:debian:debian_linux:libspice-client-gtk-2.0-dev, p-cpe:/a:debian:debian_linux:libspice-client-gtk-3.0-4, p-cpe:/a:debian:debian_linux:libspice-client-gtk-3.0-dev, p-cpe:/a:debian:debian_linux:python-spice-client-gtk, p-cpe:/a:debian:debian_linux:spice-client-glib-usb-acl-helper, p-cpe:/a:debian:debian_linux:spice-client-gtk, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/31

Reference Information

CVE: CVE-2018-10873