Debian DLA-1486-1 : spice security update

Medium Nessus Plugin ID 112225

Synopsis

The remote Debian host is missing a security update.

Description

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.

The issue has been fixed by upstream by bailing out with an error if the pointer to the start of some message data is strictly greater than the pointer to the end of the message data.

For Debian 8 'Jessie', this problem has been fixed in version 0.12.5-1+deb8u6.

We recommend that you upgrade your spice packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00037.html

https://packages.debian.org/source/jessie/spice

Plugin Details

Severity: Medium

ID: 112225

File Name: debian_DLA-1486.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/09/04

Modified: 2018/10/11

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libspice-server-dev, p-cpe:/a:debian:debian_linux:libspice-server1, p-cpe:/a:debian:debian_linux:libspice-server1-dbg, p-cpe:/a:debian:debian_linux:spice-client, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/31

Reference Information

CVE: CVE-2018-10873