VLC Media Player <= 2.2.8 Use-After-Free RCE

Medium Nessus Plugin ID 112216

Synopsis

A media player installed on the remote host is affected by a remote code execution vulnerability.

Description

The version of VLC media player installed on the remote host is equal or prior to 2.2.8. It is, therefore, affected by a use-after-free vulnerability. An attacker could leverage this vulnerability to cause a denial of service or potentially execute arbitrary code.

Solution

Upgrade to VLC version 3.0.3 or later.

See Also

http://seclists.org/fulldisclosure/2018/Jul/28

Plugin Details

Severity: Medium

ID: 112216

File Name: vlc_2_2_8.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 2018/08/31

Modified: 2018/09/17

Dependencies: 31852

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Nvd score unavailable. file payload rce

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: installed_sw/VLC media player

Patch Publication Date: 2018/05/29

Vulnerability Publication Date: 2018/07/09

Reference Information

CVE: CVE-2018-11529