Ansible Tower 3.1.x < 3.1.8 / 3.2.x < 3.2.6 CSRF vulnerability

Medium Nessus Plugin ID 112212

Synopsis

An IT monitoring application running on the remote host is affected by a CSRF vulnerability.

Description

The version of Ansible Tower running on the remote web server is 3.1.x prior to 3.1.8 or 3.2.x prior to 3.2.6. It is, therefore, affected by a cross-site request forgery vulnerability in awx/api/authentication.py.

Solution

Upgrade to Ansible Tower version 3.1.8/ 3.2.6 or later.

See Also

http://www.nessus.org/u?853d1997

http://www.nessus.org/u?60db231b

Plugin Details

Severity: Medium

ID: 112212

File Name: ansible_tower_3_2_6.nasl

Version: 1.2

Type: combined

Family: CGI abuses

Published: 2018/08/31

Modified: 2018/09/17

Dependencies: 112215, 112214

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 6.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:ansible:tower

Patch Publication Date: 2018/08/13

Vulnerability Publication Date: 2018/08/13

Reference Information

CVE: CVE-2018-10884

BID: 105136

IAVB: 2018-B-0117