Debian DLA-1482-1 : libx11 security update

High Nessus Plugin ID 112184

Synopsis

The remote Debian host is missing a security update.

Description

Several issues were discovered in libx11, the client interface to the X Windows System. The functions XGetFontPath, XListExtensions, and XListFonts are vulnerable to an off-by-one override on malicious server responses. A malicious server could also send a reply in which the first string overflows, causing a variable set to NULL that will be freed later on, leading to a segmentation fault and Denial of Service. The function XListExtensions in ListExt.c interprets a variable as signed instead of unsigned, resulting in an out-of-bounds write (of up to 128 bytes), leading to a Denial of Service or possibly remote code execution.

For Debian 8 'Jessie', these problems have been fixed in version 2:1.6.2-3+deb8u2.

We recommend that you upgrade your libx11 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00030.html

https://packages.debian.org/source/jessie/libx11

Plugin Details

Severity: High

ID: 112184

File Name: debian_DLA-1482.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/30

Modified: 2018/08/30

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libx11-6, p-cpe:/a:debian:debian_linux:libx11-6-dbg, p-cpe:/a:debian:debian_linux:libx11-6-udeb, p-cpe:/a:debian:debian_linux:libx11-data, p-cpe:/a:debian:debian_linux:libx11-dev, p-cpe:/a:debian:debian_linux:libx11-doc, p-cpe:/a:debian:debian_linux:libx11-xcb-dev, p-cpe:/a:debian:debian_linux:libx11-xcb1, p-cpe:/a:debian:debian_linux:libx11-xcb1-dbg, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/29

Reference Information

CVE: CVE-2018-14598, CVE-2018-14599, CVE-2018-14600