Joomla! < 3.8.12 Multiple Vulnerabilities

Medium Nessus Plugin ID 112160


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the Joomla! installation running on the remote web server is prior to 3.8.12. It is, therefore, affected by malicious file upload and stored cross-site scripting vulnerabilities. Additionally, versions 3.7.0 through 3.8.11 are affected by an access control list violation vulnerability.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 3.8.12 or later.

See Also

Plugin Details

Severity: Medium

ID: 112160

File Name: joomla_3812.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/08/28

Modified: 2018/09/17

Dependencies: 21142

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Nvd score unavailable. phar file upload

CVSS v2.0

Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Patch Publication Date: 2018/08/28

Vulnerability Publication Date: 2018/07/10

Reference Information

CVE: CVE-2018-15880, CVE-2018-15881, CVE-2018-15882

BID: 105161, 105164, 105166

IAVA: 2018-A-0281