Debian DLA-1476-1 : dropbear security update

High Nessus Plugin ID 112125

Synopsis

The remote Debian host is missing a security update.

Description

A vulnerability in dropbear, a lightweight SSH2 server and client, making it possible to guess valid usernames has been found :

CVE-2018-15599 :

The recv_msg_userauth_request function in svr-auth.c in is prone to a user enumeration vulnerability, similar to CVE-2018-15473 in OpenSSH.

For Debian 8 'Jessie', this problem has been fixed in version 2014.65-1+deb8u3.

We recommend that you upgrade your dropbear packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected dropbear package.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00026.html

https://packages.debian.org/source/jessie/dropbear

Plugin Details

Severity: High

ID: 112125

File Name: debian_DLA-1476.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/27

Modified: 2018/08/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:dropbear, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/27

Reference Information

CVE: CVE-2018-15599