OpenSSL 1.1.0 < 1.1.0i Multiple Vulnerabilities

Medium Nessus Plugin ID 112120

Synopsis

A service running on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of OpenSSL running on the remote host is 1.1.0 prior to 1.1.0i. It is, therefore, affected by a denial of service vulnerability and a cache timing side channel vulnerability.

Solution

Apply the vendor patch or upgrade to OpenSSL version 1.1.0i or later.

See Also

https://www.openssl.org/news/secadv/20180612.txt

https://www.openssl.org/news/secadv/20180416.txt

Plugin Details

Severity: Medium

ID: 112120

File Name: openssl_1_1_0i.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2018/08/27

Modified: 2018/09/17

Dependencies: 57323

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-0732

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Patch Publication Date: 2018/08/14

Vulnerability Publication Date: 2018/04/16

Reference Information

CVE: CVE-2018-0732, CVE-2018-0737

BID: 103766, 104442

IAVA: 2018-A-0277