Apache < 2.0.44 Illegal Character Default Script Mapping Bypass

Medium Nessus Plugin ID 11210

Synopsis

The remote web server is affected by a request file disclosure vulnerability.

Description

The remote host appears to be running a version of Apache for Windows that is older than 2.0.44. Such versions are reportedly affected by a flaw that allows an attacker to read files that they should not have access to by appending special characters to them.

Solution

Upgrade to Apache 2.0.44 or later.

See Also

https://marc.info/?l=apache-httpd-announce&m=104313442901017&w=2

Plugin Details

Severity: Medium

ID: 11210

File Name: apache_win32_read_files.nasl

Version: 1.28

Type: remote

Family: Web Servers

Published: 2003/01/22

Updated: 2018/11/15

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2003/01/22

Reference Information

CVE: CVE-2003-0017

BID: 6660

Secunia: 20493