Adobe Photoshop CC 18.x < 18.1.6 / 19.x < 19.1.6 Multiple Vulnerabilities (APSB18-28) (macOS)

High Nessus Plugin ID 112060

Synopsis

The remote host has an application installed that is affected by two remote code execution vulnerabilities.

Description

The version of Adobe Photoshop CC installed on the remote macOS or Mac OS X host is 18.x prior to 18.1.6 (2017.1.6) or 19.x prior to 19.1.6 (2018.1.6). It is, therefore, affected by two unspecified remote code execution vulnerabilities.

Solution

Upgrade to Adobe Photoshop CC 18.1.6 (2017.1.6), 19.1.6 (2018.1.6), or later.

See Also

https://helpx.adobe.com/security/products/photoshop/apsb18-28.html

Plugin Details

Severity: High

ID: 112060

File Name: macos_adobe_photoshop_apsb18-28.nasl

Version: 1.4

Type: local

Agent: macosx

Published: 2018/08/22

Modified: 2018/11/15

Dependencies: 62220

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Nvd score unavailable. remote code execution

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:adobe:photoshop_cc

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Photoshop

Patch Publication Date: 2018/08/22

Vulnerability Publication Date: 2018/08/22

Reference Information

CVE: CVE-2018-12810, CVE-2018-12811

BID: 105123