Elasticsearch ESA-2017-10

Medium Nessus Plugin ID 112040

Synopsis

The remote web server hosts a Java application that is affected by an unauthorised information disclosure vulnerability.

Description

Elasticsearch X-Pack Security versions 5.0.0 to 5.4.3, when enabled, can result in the Elasticsearch _nodes API leaking sensitive configuration information, such as the paths and passphrases of SSL keys that were configured as part of an authentication realm. This could allow an authenticated Elasticsearch user to improperly view these details.

Solution

All users of X-Pack security should upgrade to version 5.5.0. This update will prevent the _nodes API from returning sensitive settings.
If you cannot upgrade any sensitive settings can be hidden by using the X-Pack hide_settings configuration option.

See Also

http://www.nessus.org/u?e560bccc

https://www.elastic.co/community/security

Plugin Details

Severity: Medium

ID: 112040

File Name: elasticsearch_esa_2017_10.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2018/08/22

Modified: 2018/08/22

Dependencies: 109941

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-8442

CVSS v2.0

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:elastic:x-pack

Required KB Items: installed_sw/Elasticsearch

Patch Publication Date: 2017/07/06

Vulnerability Publication Date: 2017/07/06

Reference Information

CVE: CVE-2017-8442