Debian DSA-4278-1 : jetty9 - security update

High Nessus Plugin ID 111987

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in Jetty, a Java servlet engine and webserver which could result in HTTP request smuggling.

Solution

Upgrade the jetty9 packages.

For the stable distribution (stretch), these problems have been fixed in version 9.2.21-1+deb9u1.

See Also

https://security-tracker.debian.org/tracker/source-package/jetty9

https://packages.debian.org/source/stretch/jetty9

https://www.debian.org/security/2018/dsa-4278

Plugin Details

Severity: High

ID: 111987

File Name: debian_DSA-4278.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2018/08/20

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:jetty9, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/19

Reference Information

CVE: CVE-2017-7656, CVE-2017-7657, CVE-2017-7658

DSA: 4278