VMware Workstation 14.x < 14.1.3 Out-of-Bounds Write (VMSA-2018-0022) (Linux)

High Nessus Plugin ID 111976

Synopsis

A virtualization application installed on the remote Linux host is affected by an out-of-bounds write vulnerability.

Description

The version of VMware Workstation installed on the remote Linux host is 14.x prior to 14.1.3. It is, therefore, missing a security update that fixes an out-of-bounds write vulnerability.

Solution

Upgrade to VMware Workstation version 14.1.3 or later.

See Also

https://www.vmware.com/us/security/advisories/VMSA-2018-0022.html

Plugin Details

Severity: High

ID: 111976

File Name: vmware_workstation_linux_vmsa_2018_0022.nasl

Version: 1.4

Type: local

Family: General

Published: 2018/08/20

Updated: 2019/11/04

Dependencies: 71053

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6973

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version

Excluded KB Items: SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/08/14

Vulnerability Publication Date: 2018/08/14

Reference Information

CVE: CVE-2018-6973

BID: 105094

VMSA: 2018-0022