3Com NBX ftpd CEL Command Remote Overflow (1)

High Nessus Plugin ID 11185


The remote FTP server is affected by a buffer overflow vulnerability.


According to its banner, the remote FTP server is a version of VxWorks ftpd between 5.4 and 5.4.2. Such versions are known to be affected by a buffer overflow that can be triggered with an overly-long 'CEL' command. This problem is similar to the 'aix ftpd' overflow but on embedded VxWorks-based systems like the 3Com NBX IP phone call manager and seems to cause the server to crash.


If you are using an embedded VxWorks product, please contact the OEM vendor and reference WindRiver field patch TSR 296292. If this is the 3Com NBX IP Phone call manager, contact 3Com.

See Also



Plugin Details

Severity: High

ID: 11185

File Name: vxworks_ftpd.nasl

Version: $Revision: 1.22 $

Type: remote

Family: FTP

Published: 2002/12/02

Modified: 2016/11/03

Dependencies: 10092

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:C

Vulnerability Information

Required KB Items: ftp/vxftpd

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2002/12/02

Reference Information

CVE: CVE-2002-2300

BID: 6297

OSVDB: 13576, 17618

CWE: 119