Apache 2.4.x < 2.4.34 Multiple Vulnerabilities

Medium Nessus Plugin ID 111788

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.34. It is, therefore, affected by the following vulnerabilities:

- By specially crafting HTTP/2 requests, workers would be allocated 60 seconds longer than necessary, leading to worker exhaustion and a denial of service. (CVE-2018-1333)

- By specially crafting HTTP requests, the mod_md challenge handler would dereference a NULL pointer and cause the child process to segfault. This could be used to DoS the server. (CVE-2018-8011)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.34 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.34

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.34

Plugin Details

Severity: Medium

ID: 111788

File Name: apache_2_4_34.nasl

Version: 1.4

Type: remote

Family: Web Servers

Published: 2018/08/16

Updated: 2018/12/13

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-1333

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

Required KB Items: installed_sw/Apache

Patch Publication Date: 2018/07/15

Vulnerability Publication Date: 2018/07/15

Reference Information

CVE: CVE-2018-1333, CVE-2018-8011