VMware vCenter Server 5.5.x / 6.0.x / 6.5.x / 6.7.x Speculative Execution Side Channel Vulnerability (Foreshadow) (VMSA-2018-0020)

Medium Nessus Plugin ID 111760

Synopsis

A virtualization management application installed on the remote host is affected by a speculative execution side channel vulnerability.

Description

The version of VMware vCenter Server installed on the remote host is 5.5.x prior to 5.5u3j, 6.0.x prior to 6.0u3h, 6.5.x prior to 6.5u2c, or 6.7.x prior to 6.7.0d. It is, therefore, affected by a speculative execution side channel attack known as L1 Terminal Fault (L1TF). An attacker who successfully exploited L1TF may be able to read privileged data across trust boundaries.

Solution

Upgrade to the version, or later, referenced in the vendor advisory.

See Also

https://www.vmware.com/security/advisories/VMSA-2018-0020.html

https://foreshadowattack.eu/

Plugin Details

Severity: Medium

ID: 111760

File Name: vmware_vcenter_vmsa-2018-0020.nasl

Version: 1.11

Type: remote

Family: Misc.

Published: 2018/08/15

Updated: 2019/11/04

Dependencies: 63061

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-3646

CVSS Score Rationale: Nvd score unavailable. information disclosure vulnerability.

CVSS v2.0

Base Score: 4.7

Temporal Score: 3.5

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Required KB Items: Host/VMware/vCenter, Host/VMware/version, Host/VMware/release

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/08/14

Vulnerability Publication Date: 2018/08/14

Reference Information

CVE: CVE-2018-3646

BID: 105080

VMSA: 2018-0020