Debian DSA-4271-1 : samba - security update

Medium Nessus Plugin ID 111706

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in Samba, a SMB/CIFS file, print, and login server for Unix. The Common Vulnerabilities and Exposures project identifies the following issues :

- CVE-2018-10858 Svyatoslav Phirsov discovered that insufficient input validation in libsmbclient allowed a malicious Samba server to write to the client's heap memory.

- CVE-2018-10919 Phillip Kuhrt discovered that Samba when acting as an Active Domain controller disclosed some sensitive attributes.

Solution

Upgrade the samba packages.

For the stable distribution (stretch), these problems have been fixed in version 2:4.5.12+dfsg-2+deb9u3.

See Also

https://security-tracker.debian.org/tracker/CVE-2018-10858

https://security-tracker.debian.org/tracker/CVE-2018-10919

https://security-tracker.debian.org/tracker/source-package/samba

https://packages.debian.org/source/stretch/samba

https://www.debian.org/security/2018/dsa-4271

Plugin Details

Severity: Medium

ID: 111706

File Name: debian_DSA-4271.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/08/15

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:samba, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/14

Reference Information

CVE: CVE-2018-10858, CVE-2018-10919

DSA: 4271