Debian DLA-1462-1 : wpa security update

High Nessus Plugin ID 111618

Synopsis

The remote Debian host is missing a security update.

Description

The following vulnerability was discovered in wpa_supplicant.

CVE-2018-14526: | An issue was discovered in rsn_supp/wpa.c in wpa_supplicant 2.0 | through 2.6. Under certain conditions, the integrity of EAPOL-Key | messages is not checked, leading to a decryption oracle. An attacker | within range of the Access Point and client can abuse the | vulnerability to recover sensitive information.

For Debian 8 'Jessie', this problem has been fixed in version 2.3-1+deb8u6.

We recommend that you upgrade your wpa packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00009.html

https://packages.debian.org/source/jessie/wpa

Plugin Details

Severity: High

ID: 111618

File Name: debian_DLA-1462.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/10

Modified: 2018/08/10

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:hostapd, p-cpe:/a:debian:debian_linux:wpagui, p-cpe:/a:debian:debian_linux:wpasupplicant, p-cpe:/a:debian:debian_linux:wpasupplicant-udeb, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/09

Reference Information

CVE: CVE-2018-14526