Amazon Linux 2 : gnupg2 (ALAS-2018-1045)

Medium Nessus Plugin ID 111605

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

A data validation flaw was found in the way gnupg processes file names during decryption and signature validation. An attacker may be able to inject messages into gnupg verbose message logging which may have the potential to bypass the integrity of signature authentication mechanisms and could have other unintended consequences if applications take action(s) based on parsed verbose gnupg output.(CVE-2018-12020)

Solution

Run 'yum update gnupg2' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2018-1045.html

Plugin Details

Severity: Medium

ID: 111605

File Name: al2_ALAS-2018-1045.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/08/10

Modified: 2018/08/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:gnupg2, p-cpe:/a:amazon:linux:gnupg2-debuginfo, p-cpe:/a:amazon:linux:gnupg2-smime, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2018/08/08

Reference Information

CVE: CVE-2018-12020

ALAS: 2018-1045