Jenkins < 2.121.2 / 2.133 Multiple Vulnerabilities

High Nessus Plugin ID 111603

Synopsis

A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.

Description

The version of Jenkins running on the remote web server is prior to 2.133 or is a version of Jenkins LTS prior to 2.121.2. It is, therefore, affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Jenkins to version 2.133 or later, Jenkins LTS to version 2.121.2 or later.

See Also

https://jenkins.io/security/advisory/2018-07-18/

Plugin Details

Severity: High

ID: 111603

File Name: jenkins_2_133.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2018/08/09

Modified: 2018/08/09

Dependencies: 65054

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-1999001

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: www/Jenkins

Patch Publication Date: 2018/07/18

Vulnerability Publication Date: 2018/07/18

Reference Information

CVE: CVE-2018-1999001, CVE-2018-1999002, CVE-2018-1999003, CVE-2018-1999004, CVE-2018-1999005, CVE-2018-1999006, CVE-2018-1999007

IAVA: 2018-A-0246