Drupal 8.x < 8.5.6 Symfony Risky HTTP Header Restriction Bypass Vulnerability (SA-CORE-2018-005)

Medium Nessus Plugin ID 111599

Synopsis

A PHP application running on the remote web server is affected by a restriction bypass vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.x prior to 8.5.6. It is, therefore, affected by a restriction bypass vulnerability in the embedded Symfony library.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 8.5.6 or later.

See Also

https://www.drupal.org/SA-CORE-2018-005

https://www.drupal.org/project/drupal/releases/8.5.6

http://www.nessus.org/u?391e80f4

Plugin Details

Severity: Medium

ID: 111599

File Name: drupal_8_5_6.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2018/08/09

Modified: 2018/10/26

Dependencies: 18638

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-14773

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Patch Publication Date: 2018/08/01

Vulnerability Publication Date: 2018/08/01

Reference Information

CVE: CVE-2018-14773