Debian DLA-1460-1 : libmspack security update

Medium Nessus Plugin ID 111556

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there were several vulnerabilities in libsmpack, a library used to handle Microsoft compression formats.

A remote attacker could craft malicious .CAB, .CHM or .KWAJ files and use these flaws to cause a denial of service via application crash, or potentially execute arbitrary code.

For Debian 8 'Jessie', this issue has been fixed in libmspack version 0.5-1+deb8u2.

We recommend that you upgrade your libmspack packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00007.html

https://packages.debian.org/source/jessie/libmspack

Plugin Details

Severity: Medium

ID: 111556

File Name: debian_DLA-1460.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/08/07

Modified: 2018/10/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libmspack-dbg, p-cpe:/a:debian:debian_linux:libmspack-dev, p-cpe:/a:debian:debian_linux:libmspack-doc, p-cpe:/a:debian:debian_linux:libmspack0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/06

Reference Information

CVE: CVE-2018-14679, CVE-2018-14680, CVE-2018-14681, CVE-2018-14682