Debian DLA-1458-1 : xml-security-c security update

High Nessus Plugin ID 111554

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that the Apache XML Security for C++ library performed insufficient validation of KeyInfo hints, which could result in denial of service via NULL pointer dereferences when processing malformed XML data.

For Debian 8 'Jessie', this problem has been fixed in version 1.7.2-3+deb8u1.

We recommend that you upgrade your xml-security-c packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00006.html

https://packages.debian.org/source/jessie/xml-security-c

Plugin Details

Severity: High

ID: 111554

File Name: debian_DLA-1458.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/07

Modified: 2018/08/07

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxml-security-c-dev, p-cpe:/a:debian:debian_linux:libxml-security-c17, p-cpe:/a:debian:debian_linux:xml-security-c-utils, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/06