Debian DSA-4264-1 : python-django - security update

medium Nessus Plugin ID 111537
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

Andreas Hug discovered an open redirect in Django, a Python web development framework, which is exploitable ifdjango.middleware.common.CommonMiddleware is used and the APPEND_SLASH setting is enabled.

Solution

Upgrade the python-django packages.

For the stable distribution (stretch), this problem has been fixed in version 1:1.10.7-2+deb9u2.

See Also

http://www.nessus.org/u?22eb32f6

https://packages.debian.org/source/stretch/python-django

https://www.debian.org/security/2018/dsa-4264

Plugin Details

Severity: Medium

ID: 111537

File Name: debian_DSA-4264.nasl

Version: 1.4

Type: local

Agent: unix

Published: 8/6/2018

Updated: 11/13/2018

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-django:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 8/5/2018

Reference Information

CVE: CVE-2018-14574

DSA: 4264