Debian DLA-1457-1 : ant security update

High Nessus Plugin ID 111533

Synopsis

The remote Debian host is missing a security update.

Description

The fix for CVE-2018-10886 was incomplete in the previous upload. New changes was implemented upstream which check and resolve symlinks before expanding the archives.

For Debian 8 'Jessie', this problem has been fixed in version 1.9.4-3+deb8u2.

We recommend that you upgrade your ant packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/08/msg00004.html

https://packages.debian.org/source/jessie/ant

Plugin Details

Severity: High

ID: 111533

File Name: debian_DLA-1457.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/06

Modified: 2018/08/06

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ant, p-cpe:/a:debian:debian_linux:ant-doc, p-cpe:/a:debian:debian_linux:ant-gcj, p-cpe:/a:debian:debian_linux:ant-optional, p-cpe:/a:debian:debian_linux:ant-optional-gcj, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/08/05