RHEL 6 / 7 : JBoss EAP (RHSA-2018:2276)

High Nessus Plugin ID 111486

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

A security update is now available for Red Hat JBoss Enterprise Application Platform from the Customer Portal.

Red Hat Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Red Hat JBoss Enterprise Application Platform 7 is a platform for Java applications based on Wildfly.

This asynchronous patch is a security update for wildfly-core and apache-cxf packages in Red Hat JBoss Enterprise Application Platform 7.1

Security Fix(es) :

* apache-cxf: TLS hostname verification does not work correctly with com.sun.net.ssl.* (CVE-2018-8039)

* wildfly-core: Path traversal can allow the extraction of .war archives to write arbitrary files. (CVE-2018-10862)

Solution

Update the affected packages.

See Also

http://rhn.redhat.com/errata/RHSA-2018-2276.html

https://www.redhat.com/security/data/cve/CVE-2018-8039.html

https://www.redhat.com/security/data/cve/CVE-2018-10862.html

Plugin Details

Severity: High

ID: 111486

File Name: redhat-RHSA-2018-2276.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/02

Modified: 2018/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:eap7-apache-cxf, p-cpe:/a:redhat:enterprise_linux:eap7-apache-cxf-rt, p-cpe:/a:redhat:enterprise_linux:eap7-apache-cxf-services, p-cpe:/a:redhat:enterprise_linux:eap7-apache-cxf-tools, p-cpe:/a:redhat:enterprise_linux:eap7-wildfly, p-cpe:/a:redhat:enterprise_linux:eap7-wildfly-modules, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-bindings, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-policy, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-ws-security-common, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-ws-security-dom, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-ws-security-policy-stax, p-cpe:/a:redhat:enterprise_linux:eap7-wss4j-ws-security-stax, p-cpe:/a:redhat:enterprise_linux:eap7-xml-security, cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2018/07/26

Reference Information

CVE: CVE-2018-10862, CVE-2018-8039

RHSA: 2018:2276