Debian DLA-1454-1 : network-manager-vpnc security update

High Nessus Plugin ID 111467

Synopsis

The remote Debian host is missing a security update.

Description

Denis Andzakovic discovered that network-manager-vpnc, a plugin to provide VPNC support for NetworkManager, is prone to a privilege escalation vulnerability. A newline character can be used to inject a Password helper parameter into the configuration data passed to vpnc, allowing a local user with privileges to modify a system connection to execute arbitrary commands as root.

For Debian 8 'Jessie', this problem has been fixed in version 0.9.10.0-1+deb8u1.

We recommend that you upgrade your network-manager-vpnc packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00048.html

https://packages.debian.org/source/jessie/network-manager-vpnc

Plugin Details

Severity: High

ID: 111467

File Name: debian_DLA-1454.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/08/02

Modified: 2018/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:network-manager-vpnc, p-cpe:/a:debian:debian_linux:network-manager-vpnc-gnome, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/31

Reference Information

CVE: CVE-2018-10900