GLSA-201807-03 : ZNC:Multiple Vulnerabilities

Medium Nessus Plugin ID 111411

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201807-03 (ZNC:Multiple Vulnerabilities)

Multiple vulnerabilities have been discovered in ZNC. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could read arbitary files and esclate privileges.
Workaround :

There is no known workaround at this time.

Solution

All ZNC users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-irc/znc-1.7.1'

See Also

https://security.gentoo.org/glsa/201807-03

Plugin Details

Severity: Medium

ID: 111411

File Name: gentoo_GLSA-201807-03.nasl

Version: 1.2

Type: local

Published: 2018/07/30

Modified: 2018/09/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:znc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/07/29

Reference Information

CVE: CVE-2018-14055, CVE-2018-14056

GLSA: 201807-03