Debian DSA-4257-1 : fuse - security update

High Nessus Plugin ID 111395

Synopsis

The remote Debian host is missing a security-related update.

Description

Jann Horn discovered that FUSE, a Filesystem in USErspace, allows the bypass of the 'user_allow_other' restriction when SELinux is active (including in permissive mode). A local user can take advantage of this flaw in the fusermount utility to bypass the system configuration and mount a FUSE filesystem with the 'allow_other' mount option.

Solution

Upgrade the fuse packages.

For the stable distribution (stretch), this problem has been fixed in version 2.9.7-1+deb9u1.

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=904439

https://security-tracker.debian.org/tracker/fuse

https://packages.debian.org/source/stretch/fuse

http://www.debian.org/security/2018/dsa-4257

Plugin Details

Severity: High

ID: 111395

File Name: debian_DSA-4257.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/30

Modified: 2018/07/30

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:fuse, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/28

Reference Information

CVE: CVE-2018-10906

DSA: 4257