Debian DSA-4254-1 : slurm-llnl - security update

High Nessus Plugin ID 111316

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in the Simple Linux Utility for Resource Management (SLURM), a cluster resource management and job scheduling system. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2018-7033 Incomplete sanitization of user-provided text strings could lead to SQL injection attacks against slurmdbd.

- CVE-2018-10995 Insecure handling of user_name and gid fields leading to improper authentication handling.

Solution

Upgrade the slurm-llnl packages.

For the stable distribution (stretch), these problems have been fixed in version 16.05.9-1+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893044

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900548

https://security-tracker.debian.org/tracker/CVE-2018-7033

https://security-tracker.debian.org/tracker/CVE-2018-10995

https://security-tracker.debian.org/tracker/source-package/slurm-llnl

https://packages.debian.org/source/stretch/slurm-llnl

https://www.debian.org/security/2018/dsa-4254

Plugin Details

Severity: High

ID: 111316

File Name: debian_DSA-4254.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/07/25

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:slurm-llnl, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/24

Reference Information

CVE: CVE-2018-10995, CVE-2018-7033

DSA: 4254