Debian DLA-1440-1 : libarchive-zip-perl security update

High Nessus Plugin ID 111312

Synopsis

The remote Debian host is missing a security update.

Description

The libarchive-zip-perl package is vulnerable to a directory traversal attack in Archive::Zip. It was found that the Archive::Zip module did not properly sanitize paths while extracting zip files. An attacker able to provide a specially crafted archive for processing could use this flaw to write or overwrite arbitrary files in the context of the Perl interpreter.

For Debian 8 'Jessie', this problem has been fixed in version 1.39-1+deb8u1.

We recommend that you upgrade your libarchive-zip-perl packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected libarchive-zip-perl package.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00032.html

https://packages.debian.org/source/jessie/libarchive-zip-perl

Plugin Details

Severity: High

ID: 111312

File Name: debian_DLA-1440.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/25

Modified: 2018/07/25

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libarchive-zip-perl, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/24

Reference Information

CVE: CVE-2018-10860