Debian DLA-1438-1 : opencv security update

Medium Nessus Plugin ID 111223

Synopsis

The remote Debian host is missing a security update.

Description

Early versions of opencv have problems while reading data, which might result in either buffer overflows, out-of bounds errors or integer overflows.

Further assertion errors might happen due to incorrect integer cast.

For Debian 8 'Jessie', these problems have been fixed in version 2.4.9.1+dfsg-1+deb8u2.

We recommend that you upgrade your opencv packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00030.html

https://packages.debian.org/source/jessie/opencv

Plugin Details

Severity: Medium

ID: 111223

File Name: debian_DLA-1438.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/07/23

Modified: 2018/07/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:UC

CVSSv3

Base Score: 8.8

Temporal Score: 7.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:U/RC:U

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libcv-dev, p-cpe:/a:debian:debian_linux:libcv2.4, p-cpe:/a:debian:debian_linux:libcvaux-dev, p-cpe:/a:debian:debian_linux:libcvaux2.4, p-cpe:/a:debian:debian_linux:libhighgui-dev, p-cpe:/a:debian:debian_linux:libhighgui2.4, p-cpe:/a:debian:debian_linux:libopencv-calib3d-dev, p-cpe:/a:debian:debian_linux:libopencv-calib3d2.4, p-cpe:/a:debian:debian_linux:libopencv-contrib-dev, p-cpe:/a:debian:debian_linux:libopencv-contrib2.4, p-cpe:/a:debian:debian_linux:libopencv-core-dev, p-cpe:/a:debian:debian_linux:libopencv-core2.4, p-cpe:/a:debian:debian_linux:libopencv-dev, p-cpe:/a:debian:debian_linux:libopencv-features2d-dev, p-cpe:/a:debian:debian_linux:libopencv-features2d2.4, p-cpe:/a:debian:debian_linux:libopencv-flann-dev, p-cpe:/a:debian:debian_linux:libopencv-flann2.4, p-cpe:/a:debian:debian_linux:libopencv-gpu-dev, p-cpe:/a:debian:debian_linux:libopencv-gpu2.4, p-cpe:/a:debian:debian_linux:libopencv-highgui-dev, p-cpe:/a:debian:debian_linux:libopencv-highgui2.4, p-cpe:/a:debian:debian_linux:libopencv-imgproc-dev, p-cpe:/a:debian:debian_linux:libopencv-imgproc2.4, p-cpe:/a:debian:debian_linux:libopencv-legacy-dev, p-cpe:/a:debian:debian_linux:libopencv-legacy2.4, p-cpe:/a:debian:debian_linux:libopencv-ml-dev, p-cpe:/a:debian:debian_linux:libopencv-ml2.4, p-cpe:/a:debian:debian_linux:libopencv-objdetect-dev, p-cpe:/a:debian:debian_linux:libopencv-objdetect2.4, p-cpe:/a:debian:debian_linux:libopencv-ocl-dev, p-cpe:/a:debian:debian_linux:libopencv-ocl2.4, p-cpe:/a:debian:debian_linux:libopencv-photo-dev, p-cpe:/a:debian:debian_linux:libopencv-photo2.4, p-cpe:/a:debian:debian_linux:libopencv-stitching-dev, p-cpe:/a:debian:debian_linux:libopencv-stitching2.4, p-cpe:/a:debian:debian_linux:libopencv-superres-dev, p-cpe:/a:debian:debian_linux:libopencv-superres2.4, p-cpe:/a:debian:debian_linux:libopencv-ts-dev, p-cpe:/a:debian:debian_linux:libopencv-ts2.4, p-cpe:/a:debian:debian_linux:libopencv-video-dev, p-cpe:/a:debian:debian_linux:libopencv-video2.4, p-cpe:/a:debian:debian_linux:libopencv-videostab-dev, p-cpe:/a:debian:debian_linux:libopencv-videostab2.4, p-cpe:/a:debian:debian_linux:libopencv2.4-java, p-cpe:/a:debian:debian_linux:libopencv2.4-jni, p-cpe:/a:debian:debian_linux:opencv-data, p-cpe:/a:debian:debian_linux:opencv-doc, p-cpe:/a:debian:debian_linux:python-opencv, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/22

Reference Information

CVE: CVE-2016-1516, CVE-2017-1000450, CVE-2017-12597, CVE-2017-12598, CVE-2017-12599, CVE-2017-12601, CVE-2017-12603, CVE-2017-12604, CVE-2017-12605, CVE-2017-12606, CVE-2017-12862, CVE-2017-12863, CVE-2017-12864, CVE-2017-14136, CVE-2017-17760, CVE-2018-5268, CVE-2018-5269