Debian DSA-4252-1 : znc - security update

High Nessus Plugin ID 111175

Synopsis

The remote Debian host is missing a security-related update.

Description

Jeriko One discovered two vulnerabilities in the ZNC IRC bouncer which could result in privilege escalation or denial of service.

Solution

Upgrade the znc packages.

For the stable distribution (stretch), these problems have been fixed in version 1.6.5-1+deb9u1.

See Also

https://security-tracker.debian.org/tracker/znc

https://packages.debian.org/source/stretch/znc

http://www.debian.org/security/2018/dsa-4252

Plugin Details

Severity: High

ID: 111175

File Name: debian_DSA-4252.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/20

Modified: 2018/07/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:znc, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/18

Reference Information

CVE: CVE-2018-14055, CVE-2018-14056

DSA: 4252