Debian DLA-1434-1 : linux-base update

High Nessus Plugin ID 111171

Synopsis

The remote Debian host is missing a security update.

Description

The linux-base package has been updated to support the package of Linux 4.9 that was recently added to Debian 8. This resolves a dependency that was not satisfiable by the jessie and jessie-security suites.

This update also fixes a bug in version ordering in the linux-version command, corrects the package name printed by the perf command when linux-perf-4.9 is needed, and adds bash-completion support for the perf command.

For Debian 8 'Jessie', the new version is 4.5~deb8u1.

We recommend that you upgrade your linux-base packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected linux-base package.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00026.html

https://packages.debian.org/source/jessie/linux-base

Plugin Details

Severity: High

ID: 111171

File Name: debian_DLA-1434.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/20

Modified: 2018/07/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:linux-base, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/19