Debian DLA-1424-1 : linux-latest-4.9 new package

High Nessus Plugin ID 111166

Synopsis

The remote Debian host is missing a security update.

Description

Linux 4.9 has been packaged for Debian 8 as linux-4.9. This provides a supported upgrade path for systems that currently use kernel packages from the 'jessie-backports' suite.

However, 'apt full-upgrade' will *not* automatically install the updated kernel packages. You should explicitly install one of the following metapackages first, as appropriate for your system :

linux-image-4.9-686 linux-image-4.9-686-pae linux-image-4.9-amd64 linux-image-4.9-armmp linux-image-4.9-armmp-lpae linux-image-4.9-marvell

For example, if the command 'uname -r' currently shows '4.9.0-0.bpo.6-amd64', you should install linux-image-4.9-amd64.

There is no need to upgrade systems using Linux 3.16, as that kernel version will also continue to be supported in the LTS period.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00021.html

https://packages.debian.org/source/jessie/linux-latest-4.9

Plugin Details

Severity: High

ID: 111166

File Name: debian_DLA-1424.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/20

Modified: 2018/07/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:linux-headers-4.9-686, p-cpe:/a:debian:debian_linux:linux-headers-4.9-686-pae, p-cpe:/a:debian:debian_linux:linux-headers-4.9-amd64, p-cpe:/a:debian:debian_linux:linux-headers-4.9-armmp, p-cpe:/a:debian:debian_linux:linux-headers-4.9-armmp-lpae, p-cpe:/a:debian:debian_linux:linux-headers-4.9-marvell, p-cpe:/a:debian:debian_linux:linux-headers-4.9-rt-686-pae, p-cpe:/a:debian:debian_linux:linux-headers-4.9-rt-amd64, p-cpe:/a:debian:debian_linux:linux-image-4.9-686, p-cpe:/a:debian:debian_linux:linux-image-4.9-686-pae, p-cpe:/a:debian:debian_linux:linux-image-4.9-686-pae-dbg, p-cpe:/a:debian:debian_linux:linux-image-4.9-amd64, p-cpe:/a:debian:debian_linux:linux-image-4.9-amd64-dbg, p-cpe:/a:debian:debian_linux:linux-image-4.9-armmp, p-cpe:/a:debian:debian_linux:linux-image-4.9-armmp-lpae, p-cpe:/a:debian:debian_linux:linux-image-4.9-marvell, p-cpe:/a:debian:debian_linux:linux-image-4.9-rt-686-pae, p-cpe:/a:debian:debian_linux:linux-image-4.9-rt-686-pae-dbg, p-cpe:/a:debian:debian_linux:linux-image-4.9-rt-amd64, p-cpe:/a:debian:debian_linux:linux-image-4.9-rt-amd64-dbg, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/18