Oracle Java SE Multiple Vulnerabilities (July 2018 CPU) (Unix)

High Nessus Plugin ID 111162

Synopsis

The remote Unix host contains a programming platform that is affected by multiple vulnerabilities.

Description

The version of Oracle (formerly Sun) Java SE or Java for Business installed on the remote host is prior to 10 Update 2, 8 Update 181, 7 Update 191, or 6 Update 201. It is, therefore, affected by multiple vulnerabilities related to the following components :

- Concurrency
- Deployment
- JSSE
- Java DB
- JavaFX
- Libraries
- Security
- Windows DLL

Solution

Upgrade to Oracle JDK / JRE 10 Update 2, 8 Update 181 / 7 Update 191 / 6 Update 201 or later. If necessary, remove any affected versions.

Note that an Extended Support contract with Oracle is needed to obtain JDK / JRE 6 Update 95 or later.

See Also

http://www.nessus.org/u?dbb3b1db

http://www.nessus.org/u?ef524bbb

http://www.nessus.org/u?457b5e5e

http://www.nessus.org/u?4f2226dc

http://www.nessus.org/u?726f7054

Plugin Details

Severity: High

ID: 111162

File Name: oracle_java_cpu_jul_2018_unix.nasl

Version: 1.1

Type: local

Agent: unix

Family: Misc.

Published: 2018/07/20

Modified: 2018/07/20

Dependencies: 64815

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSSv3

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:oracle:jre, cpe:/a:oracle:jdk

Required KB Items: Host/Java/JRE/Installed

Patch Publication Date: 2018/07/17

Vulnerability Publication Date: 2018/07/17

Reference Information

CVE: CVE-2018-2938, CVE-2018-2940, CVE-2018-2941, CVE-2018-2952, CVE-2018-2964, CVE-2018-2972, CVE-2018-2973

BID: 104765, 104768, 104773, 104774, 104775, 104780, 104782

IAVA: 2018-A-0227