Joomla! < 3.8.9 XSS vulnerability in language switcher module

Medium Nessus Plugin ID 111064

Synopsis

The remote web server contains a PHP application that is affected by a XSS vulnerability.

Description

According to its self-reported version number, the Joomla! installation running on the remote web server is prior to 3.8.9. It is, therefore, affected by a XSS vulnerability.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 3.8.9 or later.

See Also

http://www.nessus.org/u?7670060a

Plugin Details

Severity: Medium

ID: 111064

File Name: joomla_389b.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/07/13

Modified: 2018/08/31

Dependencies: 21142

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12712

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Patch Publication Date: 2018/06/26

Vulnerability Publication Date: 2018/05/07

Reference Information

CVE: CVE-2018-12711

BID: 104565