NetApp SANtricity Web Services Proxy Unauthenticated RCE

Critical Nessus Plugin ID 110943

Synopsis

The remote host is running NetApp SANtricity Web Services Proxy that is affected by remote code execution vulnerability.

Description

NetApp SANtricity Web Services Proxy's version number is 01.10.x.x < 02.13.x.x, prior to version 02.13.x.x.
It is, therefore, affected by a remote code execution vulnerability.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's version number.

Solution

Upgrade to NetApp SANtricity Web Services Proxy version 02.13.x.x or later.
Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://nvd.nist.gov/vuln/detail/CVE-2018-5488

https://security.netapp.com/advisory/ntap-20180612-0001/

Plugin Details

Severity: Critical

ID: 110943

File Name: netapp_santricity_web_service_proxy_2_12.nasl

Version: 1.3

Type: remote

Family: Web Servers

Published: 2018/07/06

Modified: 2018/07/09

Dependencies: 110944

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2018-5488

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: x-cpe:/a:netapp:webservices

Required KB Items: Settings/ParanoidReport, installed_sw/NetApp SANtricity Web Services Proxy

Patch Publication Date: 2018/06/04

Vulnerability Publication Date: 2018/06/12

Reference Information

CVE: CVE-2018-5488

IAVA: 2018-A-0194