Debian DSA-4241-1 : libsoup2.4 - security update

High Nessus Plugin ID 110929

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that the Soup HTTP library performed insufficient validation of cookie requests which could result in an out-of-bounds memory read.

Solution

Upgrade the libsoup2.4 packages.

For the stable distribution (stretch), this problem has been fixed in version 2.56.0-2+deb9u2.

See Also

https://security-tracker.debian.org/tracker/libsoup2.4

https://packages.debian.org/source/stretch/libsoup2.4

http://www.debian.org/security/2018/dsa-4241

Plugin Details

Severity: High

ID: 110929

File Name: debian_DSA-4241.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/07/06

Modified: 2018/08/31

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libsoup2.4, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/07/05

Reference Information

CVE: CVE-2018-12910

DSA: 4241