Debian DLA-1413-1 : dokuwiki security update

High Nessus Plugin ID 110926

Synopsis

The remote Debian host is missing a security update.

Description

The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.

For Debian 8 'Jessie', these problems have been fixed in version 0.0.20140505.a+dfsg-4+deb8u1.

We recommend that you upgrade your dokuwiki packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected dokuwiki package.

See Also

https://lists.debian.org/debian-lts-announce/2018/07/msg00004.html

https://packages.debian.org/source/jessie/dokuwiki

Plugin Details

Severity: High

ID: 110926

File Name: debian_DLA-1413.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/06

Modified: 2018/07/06

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

CVSSv3

Base Score: 8.6

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:dokuwiki, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/07/05

Reference Information

CVE: CVE-2017-18123