Debian DLA-1408-1 : simplesamlphp security update

High Nessus Plugin ID 110817

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2017-12872 / CVE-2017-12868

The (1) Htpasswd authentication source in the authcrypt module and (2) SimpleSAML_Session class in SimpleSAMLphp 1.14.11 and earlier allow remote attackers to conduct timing side-channel attacks by leveraging use of the standard comparison operator to compare secret material against user input.

CVE-2017-12868 was a about an improper fix of CVE-2017-12872 in the initial patch released by upstream. We have used the correct patch.

For Debian 8 'Jessie', these problems have been fixed in version 1.13.1-2+deb8u2.

We recommend that you upgrade your simplesamlphp packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected simplesamlphp package.

See Also

https://lists.debian.org/debian-lts-announce/2018/06/msg00017.html

https://packages.debian.org/source/jessie/simplesamlphp

Plugin Details

Severity: High

ID: 110817

File Name: debian_DLA-1408.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/07/02

Modified: 2018/07/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:simplesamlphp, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/06/29

Reference Information

CVE: CVE-2017-12868, CVE-2017-12872