Debian DLA-1404-1 : lava-server security update

High Nessus Plugin ID 110786

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2018-12564 Using the feature to add URLs in the submit page, a user might be able to read any file on the server that is readable by lavaserver and consists of valid yaml. So with this patch the feature is disabled again.

For Debian 8 'Jessie', these problems have been fixed in version 2014.09.1-1+deb8u1.

We recommend that you upgrade your lava-server packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/06/msg00011.html

https://packages.debian.org/source/jessie/lava-server

Plugin Details

Severity: High

ID: 110786

File Name: debian_DLA-1404.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/06/29

Modified: 2018/06/29

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:lava, p-cpe:/a:debian:debian_linux:lava-dev, p-cpe:/a:debian:debian_linux:lava-server, p-cpe:/a:debian:debian_linux:lava-server-doc, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/06/28

Reference Information

CVE: CVE-2018-12564