Debian DLA-1403-1 : zendframework security update

High Nessus Plugin ID 110785

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2016-4861 Allowing remote attackers to conduct SQL injection attacks by leveraging failure to remove comments from a SQL statement before validation.

For Debian 8 'Jessie', these problems have been fixed in version 1.12.9+dfsg-2+deb8u7.

We recommend that you upgrade your zendframework packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/06/msg00012.html

https://packages.debian.org/source/jessie/zendframework

Plugin Details

Severity: High

ID: 110785

File Name: debian_DLA-1403.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/06/29

Modified: 2018/08/08

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:zendframework, p-cpe:/a:debian:debian_linux:zendframework-bin, p-cpe:/a:debian:debian_linux:zendframework-resources, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/06/28

Reference Information

CVE: CVE-2016-4861