phpMyAdmin 4.8.x < 4.8.2 Vulnerability (PMASA-2018-4)

Medium Nessus Plugin ID 110722

Synopsis

The remote web server hosts a PHP application that is affected by file inclusion and remote code execution vulnerabilities.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.8.x prior to 4.8.2. It is, therefore, affected by the file inclusion and remote code execution vulnerabilities

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin version 4.8.2 or later.
Alternatively, apply the patch referenced in the vendor advisory.

See Also

https://www.phpmyadmin.net/security/PMASA-2018-4/

Plugin Details

Severity: Medium

ID: 110722

File Name: phpmyadmin_pmasa_2018_4.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2018/06/27

Modified: 2018/07/12

Dependencies: 17219

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-12613

CVSSv2

Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSSv3

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/06/21

Vulnerability Publication Date: 2018/06/21

Exploitable With

Metasploit (phpMyAdmin Authenticated Remote Code Execution)

Reference Information

CVE: CVE-2018-12613

BID: 104532