Debian DSA-4234-1 : lava-server - security update

High Nessus Plugin ID 110666

Synopsis

The remote Debian host is missing a security-related update.

Description

Two vulnerabilities were discovered in LAVA, a continuous integration system for deploying operating systems for running tests, which could result in information disclosure of files readable by the lavaserver system user or the execution of arbitrary code via a XMLRPC call.

Solution

Upgrade the lava-server packages.

For the stable distribution (stretch), these problems have been fixed in version 2016.12-3.

See Also

https://security-tracker.debian.org/tracker/lava-server

https://packages.debian.org/source/stretch/lava-server

http://www.debian.org/security/2018/dsa-4234

Plugin Details

Severity: High

ID: 110666

File Name: debian_DSA-4234.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/06/25

Modified: 2018/06/25

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:lava-server, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/06/22

Reference Information

CVE: CVE-2018-12564, CVE-2018-12565

DSA: 4234