Debian DSA-4233-1 : bouncycastle - security update

High Nessus Plugin ID 110665

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that the low-level interface to the RSA key pair generator of Bouncy Castle (a Java implementation of cryptographic algorithms) could perform less Miller-Rabin primality tests than expected.

Solution

Upgrade the bouncycastle packages.

For the stable distribution (stretch), this problem has been fixed in version 1.56-1+deb9u2.

See Also

https://security-tracker.debian.org/tracker/bouncycastle

https://packages.debian.org/source/stretch/bouncycastle

http://www.debian.org/security/2018/dsa-4233

Plugin Details

Severity: High

ID: 110665

File Name: debian_DSA-4233.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/06/25

Modified: 2018/06/25

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bouncycastle, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/06/22

Reference Information

CVE: CVE-2018-1000180

DSA: 4233