Facebook OSQuery Code Signing Bypass (macOS)

Medium Nessus Plugin ID 110643

Synopsis

The version of Facebook OSQuery on the remote host is affected by a code signing bypass vulnerability.

Description

The installed version of Facebook OSQuery is less than 3.2.7 and is therefore vulnerable to allowing execution of malicious binaries due to accepting forged Apple signatures.

Solution

Update Facebook OSQuery to version 3.2.7 or higher.

See Also

http://www.nessus.org/u?8e9d177b

https://github.com/facebook/osquery/releases/tag/3.2.7

https://github.com/facebook/osquery

Plugin Details

Severity: Medium

ID: 110643

File Name: macosx_facebook_osquery_3_2_7.nasl

Version: 1.1

Type: local

Agent: macosx

Published: 2018/06/22

Modified: 2018/06/22

Dependencies: 110644

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-6336

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSSv3

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: x-cpe:/a:facebook:osquery

Required KB Items: installed_sw/OSQuery

Patch Publication Date: 2018/06/11

Vulnerability Publication Date: 2018/06/12

Reference Information

CVE: CVE-2018-6336