Web Server HTTP GET Request Version Number Handling Remote Overflow

High Nessus Plugin ID 11061


The remote host is running a web server with a remote buffer overflow vulnerability.


It was possible to kill the web server by sending an HTTP GET request with a long major version number.

An attacker may exploit this vulnerability to make your web server crash continually or even execute arbitrary code on your system.


Upgrade your software or protect it with a filtering reverse proxy.

See Also


Plugin Details

Severity: High

ID: 11061

File Name: www_too_long_version.nasl

Version: $Revision: 1.32 $

Type: remote

Family: Web Servers

Published: 2002/08/06

Modified: 2016/11/01

Dependencies: 10107, 10386

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:W/RC:ND

Vulnerability Information

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2003/07/28

Reference Information

CVE: CVE-2002-1061

BID: 5319, 5320, 5322, 5324

OSVDB: 2103