OpenSSL < 0.9.6e / 0.9.7b3 Multiple Remote Vulnerabilities

Critical Nessus Plugin ID 11060


The remote service uses a library that is affected by a buffer overflow vulnerability.


The remote service seems to be using a version of OpenSSL that is older than 0.9.6e or 0.9.7-beta3.

Such versions are affected by a buffer overflow that may allow an attacker to execute arbitrary commands on the remote host with the privileges of the application itself.


Upgrade to OpenSSL version 0.9.6e / 0.9.7beta3 or later.

Plugin Details

Severity: Critical

ID: 11060

File Name: openssl_overflow_generic_test.nasl

Version: 1.55

Type: remote

Published: 2002/08/05

Modified: 2017/02/22

Dependencies: 56984

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: SSL/Supported

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2002/07/30

Vulnerability Publication Date: 2001/07/10

Exploitable With


Core Impact

Reference Information

CVE: CVE-2000-0535, CVE-2001-1141, CVE-2002-0655, CVE-2002-0656, CVE-2002-0657, CVE-2002-0659

BID: 1340, 3004, 5361, 5362, 5363, 5364, 5366

OSVDB: 3938, 3940, 3941, 3942, 3943, 853, 857

SuSE: SUSE-SA:2002:033